Back to overview
Maintenance

Node Relocation Notice

May 13 at 11:29am BST  –  May 15 at 02:22am BST
Affected services
Node #1 | UK

Resolved
May 15 at 02:22am BST

Fully completed, migration was successful

Created
May 13 at 11:29am BST

We will be relocating our node from Finland to the UK. During this transition, services may experience downtime within the scheduled window.

The planned migration will take place between May 13th and 16th. You will receive a notification via Discord once the process begins.

We kindly ask that you plan your activities accordingly.
Thank you for your understanding.